Interesting error

OS Design, Theory, and Programming

Moderator: Moderators

Interesting error

Postby hahnski07 » Fri Oct 02, 2009 3:36 am

I have been plagued the last couple weeks by an error that i thought was in the code. However, it appears that my entire kernel is cut off at 0x100200 for some reason and the rest of the memory is filled w/ 0s. I'm very confused by this.
Attachments
error.png
error.png (237.3 KiB) Viewed 13316 times
hahnski07
 
Posts: 19
Joined: Sat Jul 18, 2009 1:50 am

Re: Interesting error

Postby Andyhhp » Fri Oct 02, 2009 8:56 am

This means that your 2nd stage bootloader is only loading the first sector of the kernel

Your kernel is loaded at 0x10000 and 0x200 is 512 bytes.

Most probably, it is not decoding the File Allocator Table correctly and thinking that the first sector is also the last sector.

Hope this helps,

~Andrew
Image
Andyhhp
Moderator
 
Posts: 387
Joined: Tue Oct 23, 2007 10:05 am
Location: 127.0.0.1

Re: Interesting error

Postby hahnski07 » Fri Oct 02, 2009 11:40 am

You're right... for some reason I didn't have the last part of the kernel loading in my bootsector.

Thanks for the help
hahnski07
 
Posts: 19
Joined: Sat Jul 18, 2009 1:50 am

Re: Interesting error

Postby Andyhhp » Sat Oct 03, 2009 3:13 pm

no problem at all

does it work slightly better now?
Image
Andyhhp
Moderator
 
Posts: 387
Joined: Tue Oct 23, 2007 10:05 am
Location: 127.0.0.1


Return to Advanced OS Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron