Page 1 of 1

Bootloader 1

Posted: Fri Oct 10, 2008 5:39 pm
by Rob_52
Hello!

ive been enjoying the tutorials :>. however, i got to copying the bootloader, then i hit an error. i made the floppy disk using VFD, every thing worked, i can see it in my computer etc. However, when i run partcopy i get the error. "Divide Error" and when i run windows Debug i get the error "Disk error writing drive A".

i would like to continue with the tutorials, i wondered if any of you could help me :<.

If it helps; im useing vista ultimate.

Thanks alot, Rob. :)

Re: Bootloader 1

Posted: Fri Oct 10, 2008 11:40 pm
by Rob_52
Nevermind!

i got it fixed, it was compatability issue it seems. im now continuing with the tutorials in a VM of XP. for anyone else whos having the same problems :/

Posted: Fri Oct 10, 2008 11:41 pm
by Mike
Go inside of your Windows Explorer and see if you have an A drive that you can open.

If not, go into Virtual Floppy Drive and try the following:

(Please note that these steps was in the previous version of the tutorial but accidentally edited out. This will be fixed very soon)

1. Start VFD;
2. Click the Drive0 tab. There should be a Change... button where it reads Drive Letter. Select it.
3. A new dialog should appear. Select a drive letter (A is the most common) and select the Persistent / Global checkbox. Hit Ok.
4. It should now read A (Persistent Global) next to Drive Letter (Or similar). Click the Driver tab.
5. Select Stop (If it is currently running) and hit Start to start it up.

Please try these steps and let us know what happens.

*edit: Ah, posted to late! :) You got it working on XP? I may need to see if there is a Vista compliant program we can use then...

Posted: Sat Oct 11, 2008 12:46 am
by Rob_52
O:!

Thanks alot for your reply mike, Its working in my native operating system now, (which id much prefer to a rather laggy vm!)

Thanks Again!

Me Again...

Posted: Sat Oct 11, 2008 1:09 am
by Rob_52
Sorry about this mike, i must be a real pain.

But once i try to run the code in the bochs emulator. i get the "System Bios Must End at 0xfffff" error, and as instructed, i minus 0xfffff from 131072 (128Bytes (the size of my Bochs bios image)) to get the memory address 0xDFFFF, but once entered that in my config file. the error doesnt change? ive tried a number of address and sums. i just cant get it

<-- Really isnt my day haha.

Thanks alot, Rob :)

Posted: Sat Oct 11, 2008 1:38 am
by Mike
Sorry about this mike, i must be a real pain.

Not really :) I enjoy helping people out :D

Try it without positioning the bios image (Some newer Bochs versions dont need it)

Code: Select all

romimage:    file=BIOS-bochs-latest

Posted: Sat Oct 11, 2008 10:27 am
by Rob_52
AH! Thank you, Again!

You really do have an excellent community here, INCREDIBLY Helpfull!

Thanks again mike :D