Search found 4 matches

by digvijay
Sat Sep 03, 2011 7:36 am
Forum: Beginners
Topic: problems in tutorial 4
Replies: 3
Views: 10128

Re: problems in tutorial 4

this is my new code.even this doesn't works and the same problem persists ******************************************************* org 0x7c00 ;we are loaded at 07c00 bits 16 ;16 bits real mode start: jmp loader msg db "WELCOME TO MY OS!",0 print: lodsb or al,al jz done mov ah,0x0E ;request ...
by digvijay
Sat Sep 03, 2011 7:31 am
Forum: Beginners
Topic: problems in tutorial 4
Replies: 2
Views: 9414

problems in tutorial 4

i have made following changes to my previous code to display "welcome to my os!'. however it still doesn't works ******************************************************* org 0x7c00 ;we are loaded at 07c00 bits 16 ;16 bits real mode start: jmp loader msg db "WELCOME TO MY OS!",0 print: ...
by digvijay
Fri Sep 02, 2011 1:48 pm
Forum: Beginners
Topic: problems in tutorial 4
Replies: 3
Views: 10128

problems in tutorial 4

i have the following .asm code to display the message "WELCOME TO MY OPERATING SYSTEM!" ******************************************************* org 0x7c00 ;we are loaded at 07c00 bits 16 ;16 bits real mode start: jmp loader msg db 'WELCOME TO MY OS!',0 loader: sti ;enable interrupts xor ax...
by digvijay
Mon Aug 29, 2011 7:04 am
Forum: Beginners
Topic: help required urgently
Replies: 1
Views: 8228

help required urgently

i have created a virtual floppy with letter 'A' and formatted it from vfd control panel. my asm file is boot1.asm and it is as follows ************************boot1.asm********************** org 0x7c00 bits 16 Start: cli hlt times 510 - ($-$$) db 0 dw 0xAA55 *****************************************...